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1 Overview

The akYtec Tool Pro software allows you to configure the following akYtec devices:
– Measuring instruments and regulators (ITP-15, ITP-17)
– Programmable relays (PR103)
– Device for indication and control (SMI2-M)
– Input/Output modules (Мx210)
– Air temperature and humidity sensors (PVT100, PVT10)
– Network gateways for the akYtec Cloud service (GW-24-Cloud, GE-24-Cloud and GG-24-Cloud)
– Network gateways for converting Modbus ASCII/RTU and Modbus TCP protocols (MBC-24 and

MBC-24.Wi-Fi).

1.1 System requirements

Operating system:
– Windows 7 (SP1+) 32/64 bit
– Windows 8.1 32/64 bit
– Windows 10 32/64 bit
– Windows 11 64 bit.

NOTE
The Chart function is available only on:
– Windows 10
– Windows 11.

System libraries:
– Microsoft .NET Framework 4.8
– Microsoft Visual C++ 2015-2022.
System requirements:
– Intel Core i3 2 GHz processor
– RAM 2 GB
– Free disk space 1 GB.
An Internet connection is required for the following actions:
– akYtec Tool Pro update
– uploading firmware updates for the connected devices.

1.2 Terms and abbreviations

– Ethernet – serial communication interface
– IP address – unique network address of the node in the computer network built on the basis of

the TCP / IP protocol stack
– Modbus – application layer messaging protocol for client/server communication between devices

connected on different types of buses or networks, originally published by Modicon (now
Schneider Electric), currently supported by an independent organization Modbus-IDA (www.
modbus.org)

– RS485 – physical layer standard for an asynchronous interface in serial communication systems
– RTC — real time clock
– USB (Universal Serial Bus) – serial communication interface
– Context menu – element of the graphical interface of the operating system, which is a list of

commands that the user calls by right-clicking on the selected object to perform the desired action
– Conflict – situation that, if not resolved, prevents further operation of the device
– PC – personal computer
– RMB – right mouse button
– LMB – left mouse button
– Device – akYtec device connected to a PC.

https://www.modbus.org
https://www.modbus.org
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2 Installation

1. Download and start the installation file.
2. Select the language of the installation wizard. Click the OK button.

Fig. 2.1 Language selection

3. The installation wizard window will appear. Familiarize yourself with the information in the
window and click the Next button.

Fig. 2.2 Installation Wizard window

4. Read the license agreement, if you agree, select I accept the terms of the agreement. Click the
Next button.

https://akytec.de/en/akytectoolpro.html#product_tabs_docssoft_contents
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Fig. 2.3 License agreement window

5. Select the folder where you want to install the program. Click the Next button.

Fig. 2.4 Window to select the installation folder

NOTE
The minimum free disk space required is ~600 MB.

6. Select the folder to create the shortcut from the Start. Click the Next button.
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Fig. 2.5 Window to select the folder in the Start menu

7. If necessary, install the COM port driver for communication with the akYtec devices and create a
shortcut by checking the appropriate checkboxes. Click the Next button.

Fig. 2.6 Window to select additional tasks

8. Click the Install button.
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Fig. 2.7 Installation window

9. A window will open to display the installation process.

Fig. 2.8 Window to display the installation process

10. Wait for the installation to complete and, if necessary, check the Start application checkbox
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Fig. 2.9 Installation completion window

11. Click the Finish button.
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3 Navigating the interface

The main window will appear at the program start.

Fig. 3.1 Main window

The window contains the main menu.
After adding devices to the project, the main window will display the following:
– Device field
– Parameter field.

Fig. 3.2 Program interface
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3.1 Main menu

File

New Create new project

Open Open project

Save Save project

Save as... Save project with a new name

Settings Program settings

Help Open help

About program View information about the program

Software update Update software

Project

Add devices Add devices to the project

Delete devices Remove devices from the project

IP addresses IP addresses assignment

Read parameters Read parameter values from selected devices

Write parameters Write changed parameter values into selected devices

Factory settings Restore factory settings of the selected device

Watch list Monitor the values of the selected parameters in real time

Chart Monitor the values of selected parameters in real time in the form of a
chart

Real time clock Set the real time clock (RTC)

Password Set or change the password in the selected devices

Calibration Start akYtec Calibration



3 Navigating the interface

10akYtec GmbH - Vahrenwalder Str. 269 A - 30179 Hannover - Germany Tel.: +49 (0) 511 16 59 672–0 - www.akytec.de

Save log data Save log data from the selected devices into a file

Data logging settings Configuring data logging for the selected device

Gateway Configuring a protocol conversion gateway (available only when a
gateway is added to a project)

Modbus Sniffer Viewing data passing through the Modbus converter

Firmware update local Update the device firmware

Firmware update
online Check for available firmware updates

Restart device Soft reset device (power reset)*

Parameter list View device parameters available over network

Device information View device information

NOTE
* Restart is only available for devices added via the akYtec Auto Detection protocol.

3.2 Device field

The device field displays the devices added to the project and their parameters.

Fig. 3.3 Device field

Device status

Online Connection with the device is established.

Offline The device is disconnected.
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Edited The parameters values have been changed in akYtec Tool Pro, but
have not yet been saved in the device.

Error Invalid parameter values have been entered.

Password protected Device is password protected.

Update available Firmware update available.

Conflict The device in the network does not match the device in the project.

Right-click on the selected device to call the context menu.

Fig. 3.4 Device context menu
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3.3 Parameter field

After device was added to a project, the parameter values are displayed and edited in a table in the
parameter field.

Fig. 3.5 Parameter field

The device parameter table contains the following information:
– Name – available device parameters distributed by type
– Value – current values of device parameters. Non-editable values are grayed out, editable values

are black
– Lower limit – minimum allowed value of the parameter
– Upper limit – maximum allowed value of the parameter
– Unit – unit of measurement for the parameter
– Default value – factory setting of the device.
Use the context menu to customize the sorting and display of columns. To call the context menu,
right-click on the header of any column.

Fig. 3.6 Context menu in parameter field

To change the order of columns, left-click and hold down the header of the column you want to
move, then move it to the selected location, guided by the area indicated by the blue arrows:
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Fig. 3.7 Changing the order of columns

To change the number of displayed columns, select the Show Column Chooser command in
the context menu of the parameter field. The Column Chooser window will appear. Left-click and
hold down the header of the column you want to hide, and then move it to the Column Chooser
window. Columns moved into the window are not displayed in the device parameter field.

Fig. 3.8 Moving a column to the Column Chooser window

NOTE
The Value column cannot be hidden or moved.

You can return the columns to the parameter field by dragging them back from the Column
Chooser window.
To hide the Column Chooser window, click the cross in the upper right corner of the window, or

select the Hide Column Chooser command in the context menu of the parameter field.
To change the width of a column, hover the cursor over the border of the column header whose
width you want to change. A two-headed arrow will appear. Left-click and select the desired column
width.
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Fig. 3.9 Changing the column width

You can set the width of the columns according to the data in them using the Best Fit command
for one column, or Best Fit (all columns) for all columns of the device parameter table.

To display the search panel, select the Show Search Panel command from the context menu
of the parameter field. Enter the name or part of the parameter name and the table will display the
parameters and categories whose names contain the entered text.

Fig. 3.10 Search in the parameter field

Click the Close button to hide the input field.
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4 Operation

1. Download and start the installation file from www.akytec.de.
2. Install and start akYtec Tool Pro.
3. Connect the device to the PC according to the device user guide.
4. Add the device to the project depending on the PC connection interface:

– Ethernet
– COM port (RS485 or USB)
– Wi-Fi
– Offline.

5. Configure the parameters and load the parameter values into the device.
6. Save the project for future use.
In akYtec Tool Pro, you can also view the current device parameters.

https://akytec.de/en/akytectoolpro.html#product_tabs_docssoft_contents
https://www.akytec.de
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5 Adding devices to the project

Fig. 5.1 Adding devices diagram

To add a device, click the Add Devices button in the Project menu. A window for selecting the
connection interface and searching for devices will appear.
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Fig. 5.2 Add devices window

A project may contain several devices operating via different protocols. The added devices can be
configured.

5.1 Interface selection

Devices can be connected to a PC via Ethernet, RS485 or Wi-Fi.
Devices connected to the PC via the RS485 and USB interface will be displayed in the program as
connected via a COM port. The port number and name can be viewed in the Windows Device
Manager.
Depending on the connection method, select the corresponding interface from the drop-down menu:

Fig. 5.3 Interface selection

NOTE
To configure the modules of the Mx210 series, select the STMicroelectronics Virtual COM
Port interface.

After selecting the interface, you can start searching for devices on the network.
Search settings vary depending on the connection interface.

5.2 Ethernet

Select Ethernet in the Interface drop-down menu to add a device via the Ethernet interface.
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Fig. 5.4 Ethernet selection

The device search is performed using IP addresses. Select a search method:
– Find all devices: Set the range of IP addresses to scan for a group of devices or a device whose

IP address is unknown
– Find device: Only one known IP address must be specified.
Search in the IP address range (Find all devices):
– Select Find all devices.
– In the input fields, you must specify the first and last addresses.
– Click the Find button to scan each IP address in the specified range. The search results for each

IP address will be displayed in the field on the right.

Fig. 5.5 Devices found

– Select the devices by checking the checkbox and click the Add devices button.
Search for a single device (Find device):
– Select Find device.
– Enter the IP address of the device in the address field.
– If necessary, enter the port number.
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Fig. 5.6 Advanced settings

– Click the Find button. The specified IP address will be scanned. The search result will be
displayed in the field on the right.

Fig. 5.7 Search for a device by its IP address

– Select the devices by checking the checkbox and click the Add devices button.
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IP address assignment
Refer to the device user guide to check whether this function is supported.
IP addresses can be assigned to one device or a group of devices.

To assign an IP address, click the IP addresses button in the Project menu. The IP assignment
window will appear:

Fig. 5.8 IP address assignment

Advanced settings
Advanced settings can be applied if the IP address is changed:
– Subnet mask
– Main gateway
– Primary and three alternate DNS servers.
To view or change the advanced settings click Show advanced settings.
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Fig. 5.9 Advanced settings

The modified advanced settings are stored in the device along with the IP address.

5.3 COM port (RS485 or USB)

To add a device connected via the RS485 or USB interface, select the number of the COM port to
which the device is connected in the Interface drop-down menu.
In the Protocol drop-down menu, select the connection protocol. Refer the protocol in the device
user guide.
akYtec Tool Pro supports the following protocols:
– Modbus RTU
– akYtec Auto Detection
– akYtec
– HART.
Each protocol requires its own settings to be set.
If the settings do not match, change the connection parameters.

5.3.1 Modbus RTU protocol

To search for devices using the Modbus protocol, select Modbus RTU in the Protocol drop-down
menu.

Fig. 5.10 Protocol selection

There are two connection modes available for the device:
1. Auto
2. Manually (network settings can be set manually).

Auto

– Select Auto in the Connection setup drop-down menu.
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Fig. 5.11 Connection setup

NOTE
When you connect for the first time, the Advanced Settings are shown.
Default settings:
– Baud rate — 9600
– Data bits — 8
– Parity — none
– Stop bits — 1.

– To search for a device with a known network address:
– Select Find device.
– Enter the device network address in the input field.

Fig. 5.12 Device address

– Click the Find button. The row with the found device will be displayed in the field on the right.
– To search for a group of devices or a device whose address is unknown, use the address
range search:
– Select Find all devices.
– In the input fields, you must specify the first and last addresses.
– Click the Find button to scan each address in the specified range. The search results for each

address will be displayed in the field on the right.

Manually

– Select Manually in the Connection setup drop-down menu.

Fig. 5.13 Connection setup

– Select the device name in the Devices drop-down menu. The names are categorized.



5 Adding devices to the project

23akYtec GmbH - Vahrenwalder Str. 269 A - 30179 Hannover - Germany Tel.: +49 (0) 511 16 59 672–0 - www.akytec.de

Fig. 5.14 Device selection

– Specify the network parameters of the device:

Fig. 5.15 Advanced settings

– To search for a device with a known network address:
– Select Find device.
– Enter the device network address in the input field.

Fig. 5.16 Device address

– Click the Find button. The row with the found device will be displayed in the field on the right.
– To search for a group of devices or a device whose address is unknown, use the address
range search:
– Select Find all devices.
– In the input fields, you must specify the first and last addresses.
– Click the Find button to scan each address in the specified range. The search results for each

address will be displayed in the field on the right.
The color that highlights the row of the found device indicates its status.
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5.3.2 akYtec Auto Detection protocol

To search for devices, select akYtec Auto Detection in the Protocol drop-down menu.

Fig. 5.17 Protocol selection

There are two connection modes available for the device:
– Auto (recommended)
– Manually (network settings can be set manually).

Auto

– Select Auto in the Connection setup drop-down menu.

Fig. 5.18 Connection setup

– To search for a device with a known network address:
– Select Find device.
– Enter the device network address in the input field.

Fig. 5.19 Device address

– Click the Find button. The row with the found device will be displayed in the field on the right.
– To search for a group of devices or a device whose address is unknown, use the address
range search:
– Select Find all devices.
– In the input fields, you must specify the first and last addresses.
– Click the Find button to scan each address in the specified range. The search results for each

address will be displayed in the field on the right.
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Fig. 5.20 Address selection

Manually

– Select Manually in the Connection setup drop-down menu.

Fig. 5.21 Connection setup

– Select connection settings:
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Fig. 5.22 Connection settings

– To search for a device with a known network address:
– Select Find device.
– Enter the device network address in the input field.

Fig. 5.23 Device address

– Click the Find button. The row with the found device will be displayed in the field on the right.
– To search for a group of devices or a device whose address is unknown, use the address
range search:
– Select Find all devices.
– In the input fields, you must specify the first and last addresses.
– Click the Find button to scan each address in the specified range. The search results for each

address will be displayed in the field on the right.
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Fig. 5.24 Address selection

The color that highlights the row of the found device indicates its status.

5.3.3 akYtec protocol

5.3.3.1 Adding a device via the akYtec protocol

To search for devices using the akYtec protocol, select akYtec in the Protocol drop-down menu.

Fig. 5.25 Protocol selection

There are two connection modes available for the device:
1. Auto
2. Manually (network settings can be set manually).

Auto

– Select Auto in the Connection setup drop-down menu.

Fig. 5.26 Connection setup

NOTE
When you connect for the first time, the Advanced Settings are displayed.
Default settings:
– Baud rate — 9600
– Data bits — 8
– Parity — none
– Stop bits — 1
– Address bits — 8.

– To search for a device with a known network address:
– Select Find device.
– Enter the device network address in the input field.
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Fig. 5.27 Device address

– Click the Find button. The row with the found device will be displayed in the field on the right.
– To search for a group of devices or a device whose address is unknown, use the address range

search:
– Select Find all devices.
– In the input fields, you must specify the first and last addresses.
– Click the Find button to scan each address in the specified range. The search results for each

address will be displayed in the field on the right.

Manually

– Select Manually in the Connection setup drop-down menu.

Fig. 5.28 Connection setup

– Select the device name in the Devices drop-down menu The names are categorized.

Fig. 5.29 Device selection

NOTE
At the moment there are no devices available via the akYtec protocol.

– Select connection settings:
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Fig. 5.30 Advanced settings

– To search for a device with a known network address:
– Select Find device.
– Enter the device network address in the input field.

Fig. 5.31 Device address

– Click the Find button. The row with the found device will be displayed in the field on the right.
– To search for a group of devices or a device whose address is unknown, use the address range

search:
– Select Find all devices.
– In the input fields, you must specify the first and last addresses.
– Click the Find button to scan each address in the specified range. The search results for each

address will be displayed in the field on the right.
The color that highlights the row of the found device indicates its status.

5.3.3.2 Device conflict

A conflict situation occurs when the project device and the device in the network (real device) are not
identical although they have the same network settings.

5.3.4 HART protocol

To search for devices, select HART in the Protocol drop-down menu.

Fig. 5.32 Protocol selection

Select the device name in the Devices drop-down menu The names are categorized.
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Fig. 5.33 Device selection

NOTE
At the moment there are no devices available via the HART protocol.

To search for a device with a known network address:
– Select Find device.
– Enter the device network address in the input field.

Fig. 5.34 Device address

– Click the Find button. The row with the found device will be displayed in the field on the right.

5.4 Wi-Fi

Connect the device to the same wireless network as your PC. Select Wireless80211 in the
Interface drop-down menu.

Fig. 5.35 Wireless80211 Interface selection

The devices are searched using IP addresses. Select a search method:
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– Find all devices: set the range of IP addresses to scan for a group of devices or a device whose
IP address is unknown.

– Find device: only one known IP address must be specified.
Search in the IP address range (Find all devices):
– Select Find all devices.
– In the input fields, you must specify the first and last IP addresses.
– Click the Find button to scan each IP address in the specified range. The search results for each

IP address will be displayed in the field to the right.

Fig. 5.36 Devices found

– Select the devices by checking the checkbox and click the Add devices button.
Search for a single device (Find device):
– Select Find device.
– Enter the IP address of the device in the address field.
– If necessary, enter the port number in the input field.
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Fig. 5.37 Advanced network settings

– Click the Find button. The specified IP address will be scanned. The search result will be
displayed in the field to the right.
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Fig. 5.38 Search for a device by its IP address

5.5 Offline

Devices that are not connected to the network can still be added to the project. You can create a
configuration, set up network settings and upload them to the device after connecting it to a PC.
To add a device that is offline, select Offline from the Interface drop-down menu.
The Devices drop-down menu contains a library of devices that can be configured in akYtec Tool
Pro. The names are categorized.
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Fig. 5.39 Device selection

Select the device and click the Add button. The selected device will be added to the list in the field
on the right.

Fig. 5.40 Add device
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Select the devices to be added to the project by checking the appropriate checkboxes. Click the Add
devices button. The devices will be added to the list in the device field.

Fig. 5.41 Device offline

Set the required device settings and save the configuration to a file by clicking Save.
If the settings are correct, communication with the device will be established when the device is
connected to a PC. In case of no communication, see section Change connection parameters. Open
the configuration file of the corresponding device to write values to the device and continue with the
configuration.

5.6 Data exchange settings

Data exchange settings can be set for devices connected via the Ethernet interface and via the

akYtec Auto Detection protocol. To configure, select Settings in the File menu. In the settings
window that appears, select the General tab.
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Fig. 5.42 General settings

Set the following parameters:
– Timeout for Ethernet (ms) — valid range: 150…10000 ms.
– Response timeout when connecting via COM port, ms — valid range: 1500…10000 ms.
– Timeout for Auto Detection Protocol (ms) — valid range: 1500…300000 ms.
– Response timeout when reading/writing parameters for Modbus, ms — valid range: 150…

300000 ms.
– Response timeout when reading/writing parameters for akYtec, ms — valid range: 160…

300000 ms.
– Pause between requests in the parameter tracking window (watch list), ms — valid range:

100…300000 ms.
If the response timeout expires, a connection error or parameter read/write error will appear.

5.7 Device status

After the search is completed, the device line can be highlighted in a color depending on the status
of the device:
– Available (white): the communication with the device is established, and it can be added to the

project.

Fig. 5.43 Device online

– Not available (red): the communication with the device is not established. When you move the
cursor over the row, a tooltip with the error description will appear.
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Fig. 5.44 Communication error

– Password protected (grey): enter the correct password to add the device to the project. Click on
the device row to open the password field. After entering the correct password, the device row will
be highlighted as "Available", the device can be added to the project.

Fig. 5.45 Password-protected device

– Device not found (yellow): the device with the specified parameters has not been found. It can
be added to the project in the offline mode. As soon as a device with the same network settings is
connected to the network, the program will establish communication with it.

Fig. 5.46 Device offline

5.8 Changing connection parameters

Communication with the connected device can only be established if the connection parameters in
the project match the parameters in the network. Parameter mismatch occurs in the following cases:
– The device in the network has been replaced with another device with different settings.
– An offline device with default settings different from the settings of the connected device is added

to the project.
To edit the connection parameters, right-click on the device in the device field. Select Change
connection parameters in the device context menu.
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Fig. 5.47 Device context menu in the offline mode

Enter the correct values. Click the Apply button.
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Fig. 5.48 Window "Change connection parameters"

Once the device with the same settings is connected, it will be displayed in the project as Online
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6 Configuration

– Changing the device name
– Reading and writing the device parameters
– Real-time clock
– Password
– Firmware update
– Updating the parameter tree

6.1 Changing the device name

To change the device name:
1. Right-click the selected device in the device field.
2. Select Change device name in the context menu.

Fig. 6.1 Context menu

3. In the window that appears, enter a new device name.

Fig. 6.2 Device name window

4. Click the OK button to save the name.
After changing the device name, the device modification will appear in brackets next to the name.

Fig. 6.3 Device name after modification
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6.2 Reading and writing the device parameters

The device parameters are read when the device is added to the project.

To read the current values of the parameters from the device, select the device and click Read
parameters in the device context menu or in the Project menu.
To read the current value of an individual parameter or an individual parameter catalog, select the

parameter or parameter catalog in the parameter field and click Read parameters in the
device context menu or in the Project menu.

6.2.1 Editing device parameters

Editable parameters are displayed in the table in black font. To edit, click on the field with the
parameter value.
If the correct value is entered, the row with the modified parameter will be highlighted in green, and

the Pencil icon will appear in the name field to the right of the name.

Fig. 6.4 Correct value

If an invalid value is entered, an error message will be displayed. If the device contains a parameter
with an error, the configuration cannot be saved into the device.

Fig. 6.5 Invalid value

If the correct value is entered, it can be saved to the device. Click Save data in the Project
menu or in the device context menu.
If a password-protected device is selected, the password will be requested. After entering the correct
password, the parameters will be displayed as usual.
If communication with the device is interrupted, the parameters can nevertheless be edited, but the
changes cannot be uploaded to the device. The modified parameters can be saved and uploaded to
the device after the communication is restored.

6.2.2 Copying device parameters

In akYtec Tool Pro, you can copy parameter values. If several parameters are to be set to the same
values:
– Right-click on the corresponding parameter or group of parameters.
– Select Copy values in the context menu that appears.
– Right-click on the parameter to which you want to assign the same value.
– Select Paste values in the context menu that appears.
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NOTE
A copied parameter or parameter group can only be pasted into a parameter or parameter
group with the same properties.

Fig. 6.6 Parameter copying

If you want to set the same values for several parameters, you can copy these values.
To copy the parameters :
– Right-click on the device from which you want to copy the parameter values.
– Select Copy values in the context menu that appears.
– Right-click on the device to which you want to paste the copied parameter values.
– Select the Paste values item in the context menu that appears.

Fig. 6.7 Copying parameters between devices

6.2.3 Comparing parameters when connecting the device

akYtec Tool Pro checks whether the parameter values stored in the device coincide with the values
of the same parameters in the project. The check is carried out in the following cases:
– When opening a project.
– After changing the network settings (device is online).
– Upon first connection of the device.
If the values of the parameters do not coincide, those parameters will be highlighted in green as
edited and not saved to the device.
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Fig. 6.8 Edited and not saved parameter value

6.2.4 Group operation

The following group operations are available in akYtec Tool Pro:
– Write parameters: the parameter values will be saved to all devices in the group
– Read parameters: the parameter values will be read from all devices in the group
– Delete devices: all selected devices will be removed from the project
– Real-time clock
– Password
– Firmware update
To select several devices:
– Press and hold the Ctrl key on the PC keyboard.
– Use the cursor to mark the devices in the device field that you want to select.
The parameter field will display the parameters present in all selected devices. For identical
parameters with different values, the value field will appear empty.

6.2.5 Restoring factory settings

To restore factory settings:

1. Select a device in the device field and click Factory settings in the device context menu or
in the Project menu. Changed parameter values return to their default values.

2. Click Write parameters in the device context menu or in the Project menu.

6.3 Real-time clock

A real-time clock (RTC) can be configured in one or more devices.

To set RTC, select the devices in the device field and click Real-time clock in the device
context menu or in the Project menu.
The window will appear and display the following information:
– Date
– Time
– Time zone
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Fig. 6.9 RTC settings

To synchronize the RTC with the PC, click the Synchronize with PC button.

NOTE
The value in the Time zone field cannot be synchronized with PC and should be set
manually.

Once the saving process is complete, the information about successful transfer of the clock settings
with the list of devices that have an RTC will be displayed in a pop-up window. If the time setting fails
on one of the devices, an error message with the device's name will be displayed.

6.4 Password

A password can be set for one or several devices at a time.

To set the password, select the devices in the device field and click Password in the device
context menu or in the Project menu.
If you click the Password button for the first time, a window to create a password will appear. Enter
the password in the input field. The password must be repeated to avoid possible entry errors. Click
the Create password button.

Fig. 6.10 Create password window

After clicking the Password button again, the Change Password window will appear. To change the
password, enter the current password and the new password in the appropriate input fields.
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Fig. 6.11 Change password window

After the password has been set, a notification will appear and display the device names:
– For which the password is successfully set
– For which the password setting failed.
If there are devices with different passwords in the project, it is recommended to change the
passwords for each device separately.
The password will be requested every time before the parameters can be viewed or edited. If the
device is added to a new project, the password will be requested too.

Fig. 6.12 Password request

Password reset

For devices added over the akYtec Auto Detection protocol, the password can be reset.
To reset a password:
1. In the device field, select the devices for which you want to reset the password.

2. Click Password in the context menu of one of the devices or in the Project menu. The
Change password window will appear.

3. In the Change password window, select the Reset password tab.
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Fig. 6.13 Reset password

4. Enter the current password and click the Reset password button. A notification will appear on
the screen showing the names of devices for which the password was reset.

NOTE
If the entered password does not match all selected devices, a notification will appear
showing the names of the devices for which the password was not reset.

For other devices, refer to the device user guide for the password reset option.

6.5 Firmware update

To update the device firmware:

1. Select the devices in the device field and click Firmware update local in the device context
menu or in the Project menu. The dialog window for device firmware update will appear.

2. Select the firmware upload source:

Fig. 6.14 Select firmware upload source

– From file: specify the path to the firmware file in the dialog window.
– From list: select a firmware version available for this device model.



6 Configuration

47akYtec GmbH - Vahrenwalder Str. 269 A - 30179 Hannover - Germany Tel.: +49 (0) 511 16 59 672–0 - www.akytec.de

Fig. 6.15 Firmware list

– Update to the latest version: the latest firmware will be uploaded automatically (internet
connection required). The item is unavailable if the device already has the latest firmware
version.

3. Confirm the selection of firmware, click the Next button.

Fig. 6.16 Firmware upload window

4. The progress bar will be displayed while the firmware is being uploaded to the device.
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Fig. 6.17 Firmware update

5. Once the upload is complete, the device will automatically reboot and be added to the project.

NOTE
If any parameters were changed before the firmware update, their values will be added to
the project and highlighted in green.

Fig. 6.18 Firmware update completed

Firmware update online

An Internet connection is required to access the online server.

Click Firmware update online in the Project menu to check for firmware updates.
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Fig. 6.19 Firmware upload window

NOTE
If the No access to the Internet message is displayed in the update catalog window, check
the PC's network connection, antivirus settings for akYtec Tool Pro, or contact the network
system administration services.

Available options:
– Show updates only for project devices: the window will display updates only for devices that

have been added to the project.
– Notify about new version: – if an update appears in akYtec Tool Pro, a notification will pop up.
To upload firmware versions:
– Check the boxes next to the updates you want to upload.

– Click the Upload button. Successful loading of the firmware version is signaled by the symbol
next to the selected update.

– Click Firmware update local in the device context menu or in the Project menu. The dialog
window for device firmware update will appear.

– Select From list.
– Click the Next button.
– The selected updates will be uploaded.

6.6 Updating the parameter tree

Updating the parameter tree is available for devices with programmable logic:
1. Select a device in the device field and right-click on it.

2. In the context menu, select Update parameter tree.
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Fig. 6.20 Update parameter tree

After updating the parameter tree, the updated list will be displayed in the parameter field.
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7 Configuration of interface conversion

– Gateway
– Modbus Sniffer

7.1 Gateway

If the gateway for converting Ethernet/RS485 or Wi-Fi/RS485 interfaces is added to the project, the

Gateway function becomes available. To configure the gateway, click Gateway in the device
context menu or in the Project menu.
The gateway settings window will appear. The operating modes for MBC-24 with Ethernet and MBC-
24 with Wi-Fi have the same designation.
Following operating modes are available for the gateway:
– Ethernet (Master) – RS485 (Slave) (corresponds to Wi-Fi (Master) — RS485 (Slave))
– RS485 (Master) – Ethernet (Slave) (corresponds to RS485 (Master) — Wi-Fi (Slave)).
Depending on the selected operation mode, a connection diagram is displayed in the upper left part
of the window (for both wired and wireless modifications of MBC-24).
The parameter field also displays the network parameters of the interfaces that are read from the
gateway.

NOTE
Network settings cannot be changed while the gateway is being configured. To modify the
network parameters, make changes in the device settings tree and write the parameters to
the device. When you reopen the gateway settings after a restart, the updated parameters
will be applied.

Ethernet (Master) – RS485 (Slave)

The Ethernet (Master) – RS485 (Slave) operation mode assumes that the Network Master is on the
Ethernet.

Fig. 7.1 Ethernet (Master) – RS485 (Slave)

In the Ethernet (Master) – RS485 (Slave) operation mode, you can select following conversion
protocols for the gateway:
– Modbus ASCII
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– Modbus RTU.

RS485 (Master) – Ethernet (Slave)

The RS485 (Master) – Ethernet (Slave) operation mode assumes that the Network Master is on the
RS485.

Fig. 7.2 RS485 (Master) – Ethernet (Slave)

Set the correspondence between Slave IDs of devices in the RS485 network and IP addresses and
ports in the Ethernet network. You can assign a unique Slave ID to each device in the Ethernet
network and add a comment.

Fig. 7.3 Matching device addresses

To add a new device to the table, click the Add device button.

To delete a device from the table, click Delete device in the device row.

NOTE
The maximum number of Slave devices in the RS485 (Master) – Ethernet (Slave) operation
mode is 31.

After configuring the gateway parameters, click the Write parameters button. The selected values
will be written.

7.2 Modbus Sniffer

If the Ethernet/RS485 interface conversion gateway is added to the project, the Modbus Sniffer

function becomes available. Click Modbus Sniffer in the device context menu or in the
Project menu.
Modbus Sniffer window will appear:
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Fig. 7.4 Modbus Sniffer window

To start packet capture, click the Start button. After clicking, the button will change to Stop.

To stop packet capture, click the Stop button.
After starting packet capture, the sniffer log table will be displayed in the window:

Fig. 7.5 Modbus Sniffer log

The table contains the following data:
– No. – serial number of the displayed packet
– Time – time of packet reception
– Source interface – IP address or mask of the source interface
– Transmitter interface – IP address or mask of the receiver interface
– Protocol conversion – information about protocol conversion
– Packet type – type of the transmitted packet (Request, Response)
– Information – information about Modbus protocol errors and device errors.
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All information displayed in the table is saved in a file of the *.csv format.
Clicking Open log file opens the folder where the log files are saved.
Clicking the Clear log button deletes data from the Modbus Sniffer window.

NOTE
The Clear log button deletes data from the sniffer log, but does not delete it from the *.csv
file.

The Package Data and Protocol fields are activated when a specific row in the table is selected.
The data displayed in these fields is saved in separate columns in the log file.
The Package Data field contains information about the data transmitted in the package, in HEX
format. The data structure is shown in the figure below.

Fig. 7.6 Package structure

The Protocol field contains information about the Modbus packet structure. The content of this field
depends on the request type and the converted protocols.
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8 Viewing parameters

– Watch list
– Chart
– Save log data
– Parameter list
– Device information

8.1 Watch list

Watch list enables you to verify the correctness of the signal settings during commissioning and to
change parameter values in real time.

To watch the device parameters, click Watch list in the device context menu or in the Project
menu.
The Watch list window will appear:

Fig. 8.1 Watch list window

The parameters of multiple devices can be added to the Watch list.
The added parameters are saved in the Watch list as long as akYtec Tool Pro is running.
To group the parameters by device, left-click and hold the Device header, then drag it to the area
above the table indicated by the blue arrows.
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Fig. 8.2 Grouping by device

To add a parameter to the Watch list , click Add to watch list in the parameter context menu.

Fig. 8.3 Adding parameters to the watch list

Similarly, you can add all parameters of the same type to the Watch list.
To edit the values available for change, click on the parameter value and enter the correct value.
Press Enter or move the cursor to another field to send the new value to the device.
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Fig. 8.4 Editing the value

If an invalid value is entered, an error message will appear, displaying an acceptable value.
You can change the placement of rows by dragging: left-click and hold the selected row, then move it
to a new location.
To delete parameters from the Watch list, right-click on the row of the parameter you want to remove
and select:
– Delete: to delete a single parameter (also accessible via the Delete key)
– Clean the list : to delete all parameters from the list.

Fig. 8.5 Deleting parameters from the watch list

8.2 Chart

akYtec Tool Pro provides visualization of device parameters.

NOTE
The Chart function is only available for Windows 10 (32/64 bit), 11 (64 bit).

Click Chart in the Project menu.
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Fig. 8.6 Graph window

To add a parameter to the chart, open the main window and display the parameter tree in the
Parameter field. Select the desired parameter, right-click it, and choose Add to chart.

Fig. 8.7 Parameter context menu

NOTE
Parameters not intended for visualization (strings, IP addresses, etc.) will not be shown on
the graph; their current values are displayed in the Parameter field.

The Graph window displays connected devices and selected parameters. You can choose the line
type and color for each parameter:
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Fig. 8.8 Chart window with added parameters

NOTE
A maximum of 10 parameters can be displayed on the chart at the same time.
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The Graph window toolbar

Fig. 8.9 Graph window toolbar

– Start/Stop: starts or stops chart display. When started, lines for all added parameters are shown.
– Open saved files: opens the folder containing .csv files with measured parameter values.
– Original scale: resets the graph area to its original scale.
– Reset: returns the chart to its initial state. All added parameters remain, but the data display is

reset.
– Polling frequency: selects the parameter polling interval (ms).
– Until the polling ends: shows the remaining time before the poll finishes.
– Duration / PC time: toggles the X-axis between computer time and polling duration.

Parameter area of the Graph window

The Parameter area of the Graph window displays the connected devices and their parameters:

Fig. 8.10 Parameter area of the Chart window

A parameter scaling function is available on the graph. The scaling is calculated using the formula:
y` = k × y + b ,

where:
y – value of the parameter polled from the device
k – scaling factor
b – offset
y` – scaled value displayed on the graph
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Graph area

Fig. 8.11 Chart area

The graph area displays X and Y axes. The Y axis shows parameter values, and the X axis shows
either computer time or polling duration, depending on the settings. The graph updates in real time
based on the selected polling frequency and parameters.
To start displaying the parameters, click the Start button in the Graph window toolbar. Lines for all
added parameters then appear in real time.
To pause the chart, click the Stop button in the Graph window toolbar. A red vertical line marks the
start of the pause. After resuming, a second red line marks the end of the pause and the restart of
the display.
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Fig. 8.12 Pauses in the graph

To reset the graph to its initial state, use the Reset button. All parameters remain configured for
display, but recorded data is cleared.
To temporarily hide a parameter, uncheck its box in the parameter list. The parameter’s line will then
be hidden from the graph.

NOTE
Hidden parameters continue to be polled. If re-enabled, their data for the entire polling period
is displayed.

Additional features:
– Graph scaling: Zoom in or out by scrolling the mouse wheel along the X or Y axes (separate

scaling of axes) or over the graph area (scales both axes together).
– Pinning values: Mark important points on the chart to track specific moments. To pin a value,

right-click the graph line and select Pin from the context menu.
– Loss of connection: If communication with a device is lost, the graph line breaks. When the

connection is restored, the graph continues with the current value.
Exporting the parameter values
Each time the graph is started, akYtec Tool Pro automatically generates a .csv file containing the
data of the parameters added to the graph.
The storage folder is limited to 200 MB. When it reaches 90% capacity, a low disk space warning
appears. If the limit is exceeded, older files are deleted automatically.
The file name contains:

Fig. 8.13 File name

A separate file is created for each device. If communication with a device is lost, information
recording is paused. If polling is stopped or the graph is reset or ended, information recording is also
stopped.
The information in the file is saved as a table:
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Fig. 8.14 .csv file

NOTE
Editing the data in the file while the graph is running may result in data loss.

8.3 Save log data

Select the devices whose log data should be saved and click Save log data in the device
context menu or in the Project menu.
In the dialog window, specify the path to the folder where the log data files will be created, or create
a new folder by clicking the Make New Folder button.

Fig. 8.15 Select the folder to save the log

The log files of devices in the *.csv format will be saved in the specified folder. A separate log file is
created for each device.
After the log data is saved, a notification will appear confirming the save.
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Fig. 8.16 Log saving notification

Data logging settings

For devices on the new platform (e.g. MX210), the data logging setting is available.

To configure data logging, click data logging settings in the Project menu.

Fig. 8.17 Data logging settings

Parameters to configure:
– Logging interval (s): period of saving data to the log
– Number of files: maximum number of archive files
– File size (Byte)
– Archive overwrite interval: the time after which the data will be overwritten, starting with the

latest.

8.4 Parameters available over network

To view all the parameters available over the network, click Parameter list in the Project menu.
In the window that opens, all the device parameters available over the network will be displayed.
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Fig. 8.18 Parameters available over the network

The device protocol determines the columns displayed in the parameter table.
– Parameter: parameter name
– Group: name of the group containing the parameter
– Address (dec): register address in decimal notation
– Address (hex): register address in hexadecimal notation
– Number of registers: number of registers reserved for parameter storage
– Read function: read function code
– Write function: write function code
– Data type: parameter data type
Click the Save button to save the settings into a *.csv file.

8.5 Device information

To view information about the device, click Device information in the device context menu or
in the Project menu.
A window with information about the device will appear:
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Fig. 8.19 Device information window

To diagnose the device, click the Refresh button to read the current values and statuses of the
parameters, which will be displayed in the window. Correct parameters are not highlighted. Incorrect
parameters are highlighted in red.
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